hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jesse Yates (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-5547) Don't delete HFiles when in "backup mode"
Date Thu, 12 Jul 2012 15:46:35 GMT

    [ https://issues.apache.org/jira/browse/HBASE-5547?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13412887#comment-13412887
] 

Jesse Yates commented on HBASE-5547:
------------------------------------

{quote}
1. Don't delete the files, and the TTL HFile cleaner
2. The special policy that has a user facing interface to retains HFiles for certain tables
and relates that via ZK.
{quote}

Clearly, we need to have #1 (and its in the current patch). I'd be fine to refactor the table-level
retention via ZK into an example class/client (rather than as part of HBaseAdmin). However,
splitting this into two tickets seems to be more work than its worth. 

@stack, @ted - what do you think?

bq. I found it hard to wrap my head around this change, because of the refactoring of the
log cleaner; but unifying the two is good.

Yeah, the hierarchy can make the reading a little odd, but it ends up being sweet that the
HFileCleanerChore is just a constructor. Might argue for using factory, but that seemed a
bit excessive for just two classes (maybe if we need to add another file cleaner chore later).

                
> Don't delete HFiles when in "backup mode"
> -----------------------------------------
>
>                 Key: HBASE-5547
>                 URL: https://issues.apache.org/jira/browse/HBASE-5547
>             Project: HBase
>          Issue Type: New Feature
>            Reporter: Lars Hofhansl
>            Assignee: Jesse Yates
>         Attachments: hbase-5447-v8.patch, hbase-5447-v8.patch, hbase-5547-v9.patch, java_HBASE-5547_v4.patch,
java_HBASE-5547_v5.patch, java_HBASE-5547_v6.patch, java_HBASE-5547_v7.patch
>
>
> This came up in a discussion I had with Stack.
> It would be nice if HBase could be notified that a backup is in progress (via a znode
for example) and in that case either:
> 1. rename HFiles to be delete to <file>.bck
> 2. rename the HFiles into a special directory
> 3. rename them to a general trash directory (which would not need to be tied to backup
mode).
> That way it should be able to get a consistent backup based on HFiles (HDFS snapshots
or hard links would be better options here, but we do not have those).
> #1 makes cleanup a bit harder.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message