hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-4050) Update HBase metrics framework to metrics2 framework
Date Thu, 12 Jul 2012 13:16:35 GMT

    [ https://issues.apache.org/jira/browse/HBASE-4050?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13412762#comment-13412762
] 

stack commented on HBASE-4050:
------------------------------

Double license in new pom.

Is it right hardcoding the version in the sub module: "+        <version>0.95-SNAPSHOT</version>"

ditto in other new poms.

Can we keep stuff in metrics rather than metrics and metrics2 now we have this fancy pants
compatibility module?

Did you say you wanted ResourceFinder because you wanted to pass stuff on construction?  Where
are you using constructors here?

Can you do tests for you implementations (and have dependencies in these new modules against
the said hadoop versions?)

This looks great Elliott.  I'd be w/ Luke trying to make do with ServiceFinder if possible
rather than pull in ResourceFinder (Its in hbase-hadoop-compat because hbase-common is not
a dependency going by your ascii art above?)
                
> Update HBase metrics framework to metrics2 framework
> ----------------------------------------------------
>
>                 Key: HBASE-4050
>                 URL: https://issues.apache.org/jira/browse/HBASE-4050
>             Project: HBase
>          Issue Type: New Feature
>          Components: metrics
>    Affects Versions: 0.90.4
>         Environment: Java 6
>            Reporter: Eric Yang
>            Assignee: Alex Baranau
>            Priority: Critical
>             Fix For: 0.96.0
>
>         Attachments: 4050-metrics-v2.patch, 4050-metrics-v3.patch, HBASE-4050-0.patch,
HBASE-4050-1.patch, HBASE-4050-2.patch, HBASE-4050.patch
>
>
> Metrics Framework has been marked deprecated in Hadoop 0.20.203+ and 0.22+, and it might
get removed in future Hadoop release.  Hence, HBase needs to revise the dependency of MetricsContext
to use Metrics2 framework.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message