hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jesse Yates (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-5547) Don't delete HFiles when in "backup mode"
Date Sun, 22 Jul 2012 16:12:35 GMT

    [ https://issues.apache.org/jira/browse/HBASE-5547?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13420226#comment-13420226
] 

Jesse Yates commented on HBASE-5547:
------------------------------------

{quote}
Meaning either sf.getPath() or sf.getReader() was null.
{quote}

Looked through the code and can't say I see that was possible (though it seems the most likely
given the setting/checking done on the store file). Looking through the test of the code,
it doesn't look like an issue if the reader is null since it either gets closed immediately
or is re-created when needed.

The getPath() call could be bad, but its not doing anything funky and we would have seen a
warning/error earlier in the run if that had actually been a problem.

{quote}
For the addendum, if TimeToLiveHFileCleaner is removed from TestZooKeeperTableArchiveClient,
we should add test for it since it is a new class introduced by this feature.
{quote}

It is tested in o.a.h.h.master.cleaner.TestHFileCleaner. This change just cleans up the test
so we don't have to worry about interaction with the TTLCleaner.
                
> Don't delete HFiles when in "backup mode"
> -----------------------------------------
>
>                 Key: HBASE-5547
>                 URL: https://issues.apache.org/jira/browse/HBASE-5547
>             Project: HBase
>          Issue Type: New Feature
>            Reporter: Lars Hofhansl
>            Assignee: Jesse Yates
>             Fix For: 0.96.0, 0.94.2
>
>         Attachments: 5547-v12.txt, 5547-v16.txt, hbase-5447-v8.patch, hbase-5447-v8.patch,
hbase-5547-v9.patch, java_HBASE-5547.addendum, java_HBASE-5547_v13.patch, java_HBASE-5547_v14.patch,
java_HBASE-5547_v15.patch, java_HBASE-5547_v4.patch, java_HBASE-5547_v5.patch, java_HBASE-5547_v6.patch,
java_HBASE-5547_v7.patch
>
>
> This came up in a discussion I had with Stack.
> It would be nice if HBase could be notified that a backup is in progress (via a znode
for example) and in that case either:
> 1. rename HFiles to be delete to <file>.bck
> 2. rename the HFiles into a special directory
> 3. rename them to a general trash directory (which would not need to be tied to backup
mode).
> That way it should be able to get a consistent backup based on HFiles (HDFS snapshots
or hard links would be better options here, but we do not have those).
> #1 makes cleanup a bit harder.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message