hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anoop Sam John (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-6138) HadoopQA not showing the findbugs report[Trunk]
Date Fri, 01 Jun 2012 13:05:23 GMT

    [ https://issues.apache.org/jira/browse/HBASE-6138?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13287375#comment-13287375
] 

Anoop Sam John commented on HBASE-6138:
---------------------------------------

I think below change can fix the issue
In pom.xml
{code}
-            <excludeFilterFile>${parent.basedir}/dev-support/findbugs-exclude.xml</excludeFilterFile>
+            <excludeFilterFile>${parent.basedir}/../dev-support/findbugs-exclude.xml</excludeFilterFile>
{code}
                
> HadoopQA not showing the findbugs report[Trunk]
> -----------------------------------------------
>
>                 Key: HBASE-6138
>                 URL: https://issues.apache.org/jira/browse/HBASE-6138
>             Project: HBase
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 0.96.0
>            Reporter: Anoop Sam John
>             Fix For: 0.96.0
>
>
> HadoopQA shows like
>  -1 findbugs.  The patch appears to cause Findbugs (version 1.3.9) to fail.
> But not able to see any reports link
> When I checked the console output for the build I can see
> {code}
> [INFO] --- findbugs-maven-plugin:2.4.0:findbugs (default-cli) @ hbase-common ---
> [INFO] Fork Value is true
> [INFO] ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO] 
> [INFO] HBase ............................................. SUCCESS [1.890s]
> [INFO] HBase - Common .................................... FAILURE [2.238s]
> [INFO] HBase - Server .................................... SKIPPED
> [INFO] HBase - Assembly .................................. SKIPPED
> [INFO] HBase - Site ...................................... SKIPPED
> [INFO] ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 4.856s
> [INFO] Finished at: Thu May 31 03:35:35 UTC 2012
> [INFO] Final Memory: 23M/154M
> [INFO] ------------------------------------------------------------------------
> [ERROR] Could not find resource '${parent.basedir}/dev-support/findbugs-exclude.xml'.
-> [Help 1]
> [ERROR] 
> {code}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message