hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Purtell (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-6267) hbase.store.delete.expired.storefile should be true by default
Date Mon, 25 Jun 2012 17:45:44 GMT

    [ https://issues.apache.org/jira/browse/HBASE-6267?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13400714#comment-13400714
] 

Andrew Purtell commented on HBASE-6267:
---------------------------------------

bq. (if above does what I think its doing – is there a test Andy?)

TestStore#testDeleteExpiredStoreFiles, see https://issues.apache.org/jira/secure/attachment/12514057/hbase-5199.patch

bq. Is expiredSelection a good name for what is returned out of selectExpiredStoreFilesToCompact.

That's a question for Liyin the original author I think.

If we are game I can put in a trivial patch to make this on by default.



                
> hbase.store.delete.expired.storefile should be true by default
> --------------------------------------------------------------
>
>                 Key: HBASE-6267
>                 URL: https://issues.apache.org/jira/browse/HBASE-6267
>             Project: HBase
>          Issue Type: Improvement
>          Components: regionserver
>    Affects Versions: 0.96.0, 0.94.1
>            Reporter: Andrew Purtell
>
> HBASE-5199 introduces this logic into Store:
> {code}
> +      // Delete the expired store files before the compaction selection.
> +      if (conf.getBoolean("hbase.store.delete.expired.storefile", false)
> +          && (ttl != Long.MAX_VALUE) && (this.scanInfo.minVersions ==
0)) {
> +        CompactSelection expiredSelection = compactSelection
> +            .selectExpiredStoreFilesToCompact(
> +                EnvironmentEdgeManager.currentTimeMillis() - this.ttl);
> +
> +        // If there is any expired store files, delete them  by compaction.
> +        if (expiredSelection != null) {
> +          return expiredSelection;
> +        }
> +      }
> {code}
> Is there any reason why that should not be default {{true}}?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

       

Mime
View raw message