hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lars Hofhansl (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-5923) Cleanup checkAndXXX logic
Date Thu, 03 May 2012 17:18:48 GMT

    [ https://issues.apache.org/jira/browse/HBASE-5923?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13267597#comment-13267597

Lars Hofhansl commented on HBASE-5923:

Thanks Stack. These are exactly the concerns I had.

It becomes even more pronounced when looking at the 0.94 patch, which needs to have a slightly
different client facing API - since the PB stuff not exist there.

I can see a few solutions:
* Only allow using WritableByteArrayComparable, i.e. make it implied and don't even pass it
(and hence only create the dependency for HTable but not HTableInterface).
* As you said, have a separate CompareOp class that gets translated to the correct compareType
in HTable (again would allow only HTable having the dependency, but not HTableInterface)

> Cleanup checkAndXXX logic
> -------------------------
>                 Key: HBASE-5923
>                 URL: https://issues.apache.org/jira/browse/HBASE-5923
>             Project: HBase
>          Issue Type: Improvement
>          Components: client, regionserver
>            Reporter: Lars Hofhansl
>            Assignee: Lars Hofhansl
>            Priority: Minor
>             Fix For: 0.96.0, 0.94.1
>         Attachments: 5923-0.94.txt, 5923-trunk.txt
> 1. the checkAnd{Put|Delete} method that takes a CompareOP is not exposed via HTable[Interface].
> 2. there is unnecessary duplicate code in the check{Put|Delete} code in HRegionServer.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message