hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-5923) Cleanup checkAndXXX logic
Date Wed, 30 May 2012 23:31:23 GMT

    [ https://issues.apache.org/jira/browse/HBASE-5923?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13286187#comment-13286187
] 

stack commented on HBASE-5923:
------------------------------

@Lars Would suggest we make a simple standalone class w/ nought but enum in it, the enums
we need comparing.  There are a few examples out there to be inspired by:

http://docs.oracle.com/cd/E29578_01/CASAPI/cas-server-javadoc/com/endeca/itl/cas/api/ComparisonOperator.html

http://www.openoffice.org/api/docs/common/ref/com/sun/star/sheet/ConditionOperator.html

We'd then internally map to pb enum.  Ugly but less ugly than exposing pb.
                
> Cleanup checkAndXXX logic
> -------------------------
>
>                 Key: HBASE-5923
>                 URL: https://issues.apache.org/jira/browse/HBASE-5923
>             Project: HBase
>          Issue Type: Improvement
>          Components: client, regionserver
>            Reporter: Lars Hofhansl
>            Assignee: Lars Hofhansl
>            Priority: Minor
>             Fix For: 0.96.0, 0.94.1
>
>         Attachments: 5923-0.94.txt, 5923-trunk.txt
>
>
> 1. the checkAnd{Put|Delete} method that takes a CompareOP is not exposed via HTable[Interface].
> 2. there is unnecessary duplicate code in the check{Put|Delete} code in HRegionServer.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message