hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matt Corgan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-5976) Initial module naming
Date Thu, 10 May 2012 00:03:47 GMT

    [ https://issues.apache.org/jira/browse/HBASE-5976?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13271964#comment-13271964

Matt Corgan commented on HBASE-5976:

Lars - i think we have 4 options on the table:

1) We start with hbase-core.  Then i pull KeyValue out to hbase-common.  Downside here is
that we have common and core which is confusing and is likely to stick around forever.  Sounds
like we all want to avoid this.

2) We start with hbase-common and i leave KeyValue there.  We would eventually pull most of
the other stuff out to hbase-server.  The naming is good with this method, but i worry we
will be moving a majority of the files to hbase-server.

3) We start with hbase-server.  Then i pull KeyValue out to hbase-common.  Downside here is
that hbase-server is a misleading name until the client code is pulled out.

4) We start with hbase-hbase.  Then i pull KeyValue out to hbase-common (same as #3).  Downside
here is that after pulling the client code out, this should probably be renamed to something
like hbase-server.

In #3 you are pulling core interfaces "up" the dependency hierarchy, while in #2 you are pulling
implementations "down".  I initially proposed #3 because i think it will be less work to pull
the core classes out of the hairball then to pull all the implementation classes out.  Could
work either way.  I defer to Jesse since he actually attempted it.
> Initial module naming
> ---------------------
>                 Key: HBASE-5976
>                 URL: https://issues.apache.org/jira/browse/HBASE-5976
>             Project: HBase
>          Issue Type: Brainstorming
>          Components: build
>    Affects Versions: 0.96.0
>            Reporter: Jesse Yates
>   Original Estimate: 336h
>  Remaining Estimate: 336h
> There is currently a lot of discussion around the 'right' name for the initial module
that will host all the code in the primary modularization of hbase. The current contenders
> * hbase-core
> * hbase-common
> * hbase-server
> * hbase-bucket
> * hbase-hbase
> Let's duke it out and pick the best, while keeping in mind that this module will *not*
remain the sole module going forward, but is merely the precursor 
> Timeline to close this issue is the day before the code gets committed.
> Source: http://search-hadoop.com/m/pwi1t1e9K0R/modularizing+trunk&subj=modularizing+trunk

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message