hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhihong Yu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-5892) [hbck] Refactor parallel WorkItem* to Futures.
Date Wed, 30 May 2012 18:14:36 GMT

    [ https://issues.apache.org/jira/browse/HBASE-5892?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13285864#comment-13285864
] 

Zhihong Yu commented on HBASE-5892:
-----------------------------------

Minor comment:
{code}
+    List<WorkItemRegion> work = new ArrayList<WorkItemRegion>(regionServerList.size());
{code}
variable work should be named works.
{code}
+        if(hdfsEntry.hri != null) {
{code}
Insert space between if and (.

                
> [hbck] Refactor parallel WorkItem* to Futures.
> ----------------------------------------------
>
>                 Key: HBASE-5892
>                 URL: https://issues.apache.org/jira/browse/HBASE-5892
>             Project: HBase
>          Issue Type: Improvement
>            Reporter: Jonathan Hsieh
>            Assignee: Andrew Wang
>              Labels: noob
>         Attachments: hbase-5892-1.patch, hbase-5892-2-0.90.patch, hbase-5892-2.patch,
hbase-5892-3.patch, hbase-5892.patch
>
>
> This would convert WorkItem* logic (with low level notifies, and rough exception handling)
 into a more canonical Futures pattern.
> Currently there are two instances of this pattern (for loading hdfs dirs, for contacting
regionservers for assignments, and soon -- for loading hdfs .regioninfo files).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message