hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lars Hofhansl (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-1177) Delay when client is located on the same node as the regionserver
Date Mon, 21 May 2012 03:40:41 GMT

    [ https://issues.apache.org/jira/browse/HBASE-1177?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13279943#comment-13279943
] 

Lars Hofhansl commented on HBASE-1177:
--------------------------------------

If this caused by Nagles it should happen regardless of whether the DN is local to the RS
or not, right? (Or maybe we're seeing an issue different from the OP's).

                
> Delay when client is located on the same node as the regionserver
> -----------------------------------------------------------------
>
>                 Key: HBASE-1177
>                 URL: https://issues.apache.org/jira/browse/HBASE-1177
>             Project: HBase
>          Issue Type: Bug
>          Components: performance
>    Affects Versions: 0.19.0
>         Environment: Linux 2.6.25 x86_64
>            Reporter: Jonathan Gray
>              Labels: noob
>         Attachments: Contribution of getClosest to getRow time.jpg, Contribution of next
to getRow time.jpg, Contribution of seekTo to getClosest time.jpg, Elapsed time of RowResults.readFields.jpg,
ReadDelayTest.java, RowResults.readFields zoomed.jpg, getRow + round-trip vs # columns.jpg,
getRow times.jpg, screenshot-1.jpg, screenshot-2.jpg, screenshot-3.jpg, screenshot-4.jpg,
zoom of columns vs round-trip blowup.jpg
>
>
> During testing of HBASE-80, we uncovered a strange 40ms delay for random reads.  We ran
a series of tests and found that it only happens when the client is on the same node as the
RS and for a certain range of payloads (not specifically related to number of columns or size
of them, only total payload).  It appears to be precisely 40ms every time.
> Unsure if this is particular to our architecture, but it does happen on all nodes we've
tried.  Issue completely goes away with very large payloads or moving the client.
> Will post a test program tomorrow if anyone can test on a different architecture.
> Making a blocker for 0.20.  Since this happens when you have an MR task running local
to the RS, and this is what we try to do, might also consider making this a blocker for 0.19.1.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message