hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-5795) hbase-3927 breaks 0.92<->0.94 compatibility
Date Sat, 14 Apr 2012 23:39:17 GMT

    [ https://issues.apache.org/jira/browse/HBASE-5795?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13254229#comment-13254229
] 

stack commented on HBASE-5795:
------------------------------

Hmmm... not that easy.  This one messes us up too...

{code}
------------------------------------------------------------------------
r1239157 | tedyu | 2012-02-01 06:56:20 -0800 (Wed, 01 Feb 2012) | 2 lines

HBASE-5283 Request counters may become negative for heavily loaded regions (Mubarak)
{code}

The above commit depends on hbase-5256.  If hbase-5256 were not in place, this would not break
compatibility but since we have to back out hbase-5256, it does.  Looking..
                
> hbase-3927 breaks 0.92<->0.94 compatibility
> -------------------------------------------
>
>                 Key: HBASE-5795
>                 URL: https://issues.apache.org/jira/browse/HBASE-5795
>             Project: HBase
>          Issue Type: Bug
>            Reporter: stack
>            Assignee: stack
>
> This commit broke our 0.92/0.94 compatibility:
> {code}
> ------------------------------------------------------------------------
> r1136686 | stack | 2011-06-16 14:18:08 -0700 (Thu, 16 Jun 2011) | 1 line
> HBASE-3927 display total uncompressed byte size of a region in web UI
> {code}
> I just tried the new RC for 0.94.  I brought up a 0.94 master on a 0.92 cluster and rather
than just digest version 1 of the HServerLoad, I get this:
> {code}
> 2012-04-14 22:47:59,752 WARN org.apache.hadoop.ipc.HBaseServer: Unable to read call parameters
for client 10.4.14.38
> java.io.IOException: Error in readFields
>         at org.apache.hadoop.hbase.io.HbaseObjectWritable.readObject(HbaseObjectWritable.java:684)
>         at org.apache.hadoop.hbase.ipc.Invocation.readFields(Invocation.java:125)
>         at org.apache.hadoop.hbase.ipc.HBaseServer$Connection.processData(HBaseServer.java:1269)
>         at org.apache.hadoop.hbase.ipc.HBaseServer$Connection.readAndProcess(HBaseServer.java:1184)
>         at org.apache.hadoop.hbase.ipc.HBaseServer$Listener.doRead(HBaseServer.java:722)
>         at org.apache.hadoop.hbase.ipc.HBaseServer$Listener$Reader.doRunLoop(HBaseServer.java:513)
>         at org.apache.hadoop.hbase.ipc.HBaseServer$Listener$Reader.run(HBaseServer.java:488)
>         at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
>         at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
>         at java.lang.Thread.run(Thread.java:662)
> Caused by: A record version mismatch occured. Expecting v2, found v1
>         at org.apache.hadoop.io.VersionedWritable.readFields(VersionedWritable.java:46)
>         at org.apache.hadoop.hbase.HServerLoad$RegionLoad.readFields(HServerLoad.java:379)
>         at org.apache.hadoop.hbase.HServerLoad.readFields(HServerLoad.java:686)
>         at org.apache.hadoop.hbase.io.HbaseObjectWritable.readObject(HbaseObjectWritable.java:681)
>         ... 9 more
> {code}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message