hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Phabricator (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-5335) Dynamic Schema Configurations
Date Tue, 13 Mar 2012 04:41:44 GMT

    [ https://issues.apache.org/jira/browse/HBASE-5335?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13228199#comment-13228199

Phabricator commented on HBASE-5335:

stack has commented on the revision "[jira] [HBASE-5335] Dynamic Schema Config".

  Looks good.  Minor comments only.

  src/main/java/org/apache/hadoop/hbase/HColumnDescriptor.java:736 kvs is a loaded term in
hbase code base.  When I see it I think KeyValue, the class.  Mayhaps change this method name?
  src/main/java/org/apache/hadoop/hbase/HTableDescriptor.java:571 As Ted suggests, some of
the body of this method could be broken out into a common method rather than dup code.  For
example, from here to the end of the loop seems common to both.

  They both inherit WritableComparable.  Could inherit a more specialized type, one w/ support
for this and other commonage.

  No biggie.
  src/main/java/org/apache/hadoop/hbase/regionserver/HRegion.java:938 Why change name?  You
are returning the 'Configuration'.  In general, why change the name to baseConf from conf
when its just a Configuation still?
  src/main/java/org/apache/hadoop/hbase/regionserver/SplitRequest.java:41 This is better I'd
  src/main/java/org/apache/hadoop/hbase/util/CompoundConfiguration.java:48 lol

  This a warning?  There be dragons...
  src/main/java/org/apache/hadoop/hbase/util/CompoundConfiguration.java:60 Isn't hadoop Configuration
kinda wonky where there is the notion of finals and these are supposed to be at the 'front'.
 Does this 'front' go before the hadoop final 'front'?  It looks like it does which is what
we want I think.
  src/main/java/org/apache/hadoop/hbase/util/CompoundConfiguration.java:113 In the rest of
the code, we add curlies or else put if and the one line clause both on same line.  FYI.
  src/main/java/org/apache/hadoop/hbase/util/CompoundConfiguration.java:428 Why not do this
stuff in HBaseConfiguration rather than add new method?


> Dynamic Schema Configurations
> -----------------------------
>                 Key: HBASE-5335
>                 URL: https://issues.apache.org/jira/browse/HBASE-5335
>             Project: HBase
>          Issue Type: New Feature
>            Reporter: Nicolas Spiegelberg
>            Assignee: Nicolas Spiegelberg
>              Labels: configuration, schema
>         Attachments: D2247.1.patch
> Currently, the ability for a core developer to add per-table & per-CF configuration
settings is very heavyweight.  You need to add a reserved keyword all the way up the stack
& you have to support this variable long-term if you're going to expose it explicitly
to the user.  This has ended up with using Configuration.get() a lot because it is lightweight
and you can tweak settings while you're trying to understand system behavior [since there
are many config params that may never need to be tuned].  We need to add the ability to put
& read arbitrary KV settings in the HBase schema.  Combined with online schema change,
this will allow us to safely iterate on configuration settings.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message