hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Phabricator (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-5521) Move compression/decompression to an encoder specific encoding context
Date Sat, 17 Mar 2012 08:07:58 GMT

    [ https://issues.apache.org/jira/browse/HBASE-5521?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13231890#comment-13231890
] 

Phabricator commented on HBASE-5521:
------------------------------------

heyongqiang has commented on the revision "HBASE-5521 [jira] Move compression/decompression
to an encoder specific encoding context".

INLINE COMMENTS
  src/main/java/org/apache/hadoop/hbase/io/encoding/DataBlockEncoder.java:61 The interface
is there before this change.
  I agree it need a better name. But i think that should be done in a different context.
  src/main/java/org/apache/hadoop/hbase/io/encoding/HFileBlockDefaultEncodingContext.java:109
this interface is removed from the interface as to address your previous comments. Methods
defined in an interface need to be clear and need to be as fewer as possible. Once it is added,
it is not easy to take back.
  src/main/java/org/apache/hadoop/hbase/io/encoding/HFileBlockEncodingContext.java:34 Yes.
It returns encoded uncompressed bytes.
  src/main/java/org/apache/hadoop/hbase/io/encoding/EncodedDataBlock.java:202 ok. i will rename
it to encodeData()
  src/main/java/org/apache/hadoop/hbase/io/encoding/HFileBlockDefaultEncodingContext.java:106
will fix
  src/main/java/org/apache/hadoop/hbase/io/encoding/DataBlockEncoder.java:56 nope. it's 'as
well as'...will put a few more words here

REVISION DETAIL
  https://reviews.facebook.net/D2097

                
> Move compression/decompression to an encoder specific encoding context
> ----------------------------------------------------------------------
>
>                 Key: HBASE-5521
>                 URL: https://issues.apache.org/jira/browse/HBASE-5521
>             Project: HBase
>          Issue Type: Improvement
>            Reporter: He Yongqiang
>            Assignee: He Yongqiang
>         Attachments: HBASE-5521.1.patch, HBASE-5521.D2097.1.patch, HBASE-5521.D2097.2.patch,
HBASE-5521.D2097.3.patch, HBASE-5521.D2097.4.patch, HBASE-5521.D2097.5.patch, HBASE-5521.D2097.6.patch,
HBASE-5521.D2097.7.patch, HBASE-5521.D2097.8.patch
>
>
> As part of working on HBASE-5313, we want to add a new columnar encoder/decoder. It makes
sense to move compression to be part of encoder/decoder:
> 1) a scanner for a columnar encoded block can do lazy decompression to a specific part
of a key value object
> 2) avoid an extra bytes copy from encoder to hblock-writer. 
> If there is no encoder specified for a writer, the HBlock.Writer will use a default compression-context
to do something very similar to today's code.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message