hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Phabricator (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-5413) Rename RowMutation to RowMutations
Date Fri, 17 Feb 2012 00:12:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-5413?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13209903#comment-13209903

Phabricator commented on HBASE-5413:

stack has commented on the revision "HBASE-5413 [jira] Rename RowMutation to RowMutations".

  We have the notion of Operation already.  It would seem to cut across rows in that a Scan
and a RowMutations is ugly, agree, but it does convey notions of 'many' and 'in a row'.

  Regards RowOperation, Get or Put subclass Operation (actually, its subclass http://hbase.apache.org/apidocs/org/apache/hadoop/hbase/client/OperationWithAttributes.html).
   RowOperation therefore could work in that it narrows the set of Operations only, the odd
thing is that Delete does not inherit from OperationWIthAttribute.  I'd think we should fix
this hole in our 'model' if we went with RowOperation.

  If I was looking into the client package and saw both RowMutation and RowOperation sitting
beside each other, I'd think I'd be confused what to use whereas with RowMutation and RowMutuations...
I'd think I'd have some notion how they might be used.

  AtomicRowMutation I feel is w/o meaning since all Row mutations are 'atomic' -- or its a
bug - so the Atomic qualifier would seem to add nothing.

  As Thomas Pan says, just my 2c.



> Rename RowMutation to RowMutations
> ----------------------------------
>                 Key: HBASE-5413
>                 URL: https://issues.apache.org/jira/browse/HBASE-5413
>             Project: HBase
>          Issue Type: Sub-task
>          Components: client, coprocessors, regionserver
>            Reporter: Amitanand Aiyer
>            Assignee: Amitanand Aiyer
>             Fix For: 0.94.0
>         Attachments: HBASE-5413.D1755.1.patch, HBASE-5413.D1755.2.patch

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message