hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Doug Meil (Created) (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-5016) LoadBalancerFactory - "maser" in package name of dynamically loaded balancer class?
Date Tue, 13 Dec 2011 17:48:30 GMT
LoadBalancerFactory - "maser" in package name of dynamically loaded balancer class?
-----------------------------------------------------------------------------------

                 Key: HBASE-5016
                 URL: https://issues.apache.org/jira/browse/HBASE-5016
             Project: HBase
          Issue Type: Bug
            Reporter: Doug Meil



Shouldn't this... "hbase.maser.loadBalancer.class" be something like "hbase.master.loadBalancer.class"?
 What's with "maser"?

{code}

/**
 * The class that creates a load balancer from a conf.
 */
public class LoadBalancerFactory {

  /**
   * Create a loadblanacer from the given conf.
   * @param conf
   * @return A {@link LoadBalancer}
   */
  public static LoadBalancer getLoadBalancer(Configuration conf) {

    // Create the balancer
    Class<? extends LoadBalancer> balancerKlass = conf.getClass("hbase.maser.loadBalancer.class",DefaultLoadBalancer.class,
LoadBalancer.class);
    return ReflectionUtils.newInstance(balancerKlass, conf);

  }
}
{code}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message