hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ted Yu (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-4764) naming errors for TestHLogUtils and SoftValueSortedMapTest
Date Sat, 12 Nov 2011 16:21:51 GMT

    [ https://issues.apache.org/jira/browse/HBASE-4764?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13149102#comment-13149102
] 

Ted Yu commented on HBASE-4764:
-------------------------------

I think the proposal makes sense.

See also http://markphip.blogspot.com/2006/12/subversion-moverename-feature.html
                
> naming errors for TestHLogUtils and SoftValueSortedMapTest
> ----------------------------------------------------------
>
>                 Key: HBASE-4764
>                 URL: https://issues.apache.org/jira/browse/HBASE-4764
>             Project: HBase
>          Issue Type: Improvement
>          Components: test
>    Affects Versions: 0.94.0
>            Reporter: nkeywal
>            Assignee: nkeywal
>            Priority: Minor
>
> SoftValueSortedMapTest it's a test, but not a junit one, I tend to think it's not called.
I don't know if it's used.
> TestHLogUtils has a wrong name: it's not a test, but an helper. It confuses the script
looking for the tests. It would seems a better thing to rename it. Is there anything special
to do to keep the history attached to this file?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message