hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "LuiYip (Created) (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-4901) HBase BUG when I use HBaseConfiguration to load it
Date Wed, 30 Nov 2011 09:51:39 GMT
HBase BUG when I use HBaseConfiguration to load it
--------------------------------------------------

                 Key: HBASE-4901
                 URL: https://issues.apache.org/jira/browse/HBASE-4901
             Project: HBase
          Issue Type: Bug
          Components: io
    Affects Versions: 0.20.6
         Environment: Red Hat Enterprise Linux Server release 5.4
            Reporter: LuiYip


I create a class named HBaseInterfaceHolder who will hold ThreadLocal<HBaseInterface>
hBaseInterfaceHolder. But when the program run at the line (HBaseConfiguration config = new
HBaseConfiguration();), it throws a java.io.IOException:config()
at 
org.apache.hadoop.conf.Configuration.<init>(Configuration.java:211)
org.apache.hadoop.conf.Configuration.<init>(Configuration.java:198)
org.apache.hadoop.hbase.HBaseConfiguration.<init>(Configuration.java:33)
com.netentsec.niudian.phoenix.web2.hbaseinterface.HBaseInterfaceHolder$1.initialValue(HBaseInterfaceHolder.java:24)
this line is my own program which is the content in previous bracket.

I search online to find out the reason. But no forum related it.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message