hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "jiraposter@reviews.apache.org (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-3417) CacheOnWrite is using the temporary output path for block names, need to use a more consistent block naming scheme
Date Thu, 13 Oct 2011 19:39:12 GMT

    [ https://issues.apache.org/jira/browse/HBASE-3417?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13126853#comment-13126853
] 

jiraposter@reviews.apache.org commented on HBASE-3417:
------------------------------------------------------



bq.  On 2011-10-13 19:33:27, Michael Stack wrote:
bq.  > /src/main/java/org/apache/hadoop/hbase/regionserver/StoreFile.java, line 166
bq.  > <https://reviews.apache.org/r/2379/diff/2/?file=49945#file49945line166>
bq.  >
bq.  >     @Mikhail.... yeah.   I figured it out.  I was thinking we should allow dashes...
then it looks like a uuid and makes compare  by human easier.

we had this argument months ago.  there's a good consistency in the UIs w/ the current region
encoded names (used as dir names) w/ these uuid (minus -) names.  The dashes makes mismatched
(as I recall my thoughts on the matter way back when it originally had dashes).

i stand by the no dashes!  :)


- Jonathan


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/2379/#review2565
-----------------------------------------------------------


On 2011-10-13 19:36:33, Jonathan Gray wrote:
bq.  
bq.  -----------------------------------------------------------
bq.  This is an automatically generated e-mail. To reply, visit:
bq.  https://reviews.apache.org/r/2379/
bq.  -----------------------------------------------------------
bq.  
bq.  (Updated 2011-10-13 19:36:33)
bq.  
bq.  
bq.  Review request for hbase, Dhruba Borthakur, Michael Stack, and Mikhail Bautin.
bq.  
bq.  
bq.  Summary
bq.  -------
bq.  
bq.  Adds a new test that fails w/o this fix and changes the naming scheme for storefiles
to use UUID instead of random longs as ascii.
bq.  
bq.  The big change is that the name of the tmp file used when flushing and compacting is
the same name (but different dir) when moved in place.  This makes it so block names are consistent
for COW.
bq.  
bq.  
bq.  This addresses bug HBASE-3417.
bq.      https://issues.apache.org/jira/browse/HBASE-3417
bq.  
bq.  
bq.  Diffs
bq.  -----
bq.  
bq.    /src/main/java/org/apache/hadoop/hbase/io/hfile/AbstractHFileWriter.java 1183049 
bq.    /src/main/java/org/apache/hadoop/hbase/io/hfile/CacheConfig.java 1183049 
bq.    /src/main/java/org/apache/hadoop/hbase/regionserver/Store.java 1183049 
bq.    /src/main/java/org/apache/hadoop/hbase/regionserver/StoreFile.java 1183049 
bq.    /src/test/java/org/apache/hadoop/hbase/client/TestFromClientSide.java 1183049 
bq.  
bq.  Diff: https://reviews.apache.org/r/2379/diff
bq.  
bq.  
bq.  Testing
bq.  -------
bq.  
bq.  TestFromClientSide and TestCacheOnWrite both working
bq.  
bq.  
bq.  Thanks,
bq.  
bq.  Jonathan
bq.  
bq.


                
> CacheOnWrite is using the temporary output path for block names, need to use a more consistent
block naming scheme
> ------------------------------------------------------------------------------------------------------------------
>
>                 Key: HBASE-3417
>                 URL: https://issues.apache.org/jira/browse/HBASE-3417
>             Project: HBase
>          Issue Type: Bug
>          Components: io, regionserver
>    Affects Versions: 0.92.0
>            Reporter: Jonathan Gray
>            Assignee: Jonathan Gray
>            Priority: Critical
>             Fix For: 0.92.0
>
>         Attachments: HBASE-3417-redux-v1.patch, HBASE-3417-v1.patch, HBASE-3417-v2.patch,
HBASE-3417-v5.patch
>
>
> Currently the block names used in the block cache are built using the filesystem path.
 However, for cache on write, the path is a temporary output file.
> The original COW patch actually made some modifications to block naming stuff to make
it more consistent but did not do enough.  Should add a separate method somewhere for generating
block names using some more easily mocked scheme (rather than just raw path as we generate
a random unique file name twice, once for tmp and then again when moved into place).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message