hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Gray (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-3417) CacheOnWrite is using the temporary output path for block names, need to use a more consistent block naming scheme
Date Thu, 13 Oct 2011 22:14:11 GMT

    [ https://issues.apache.org/jira/browse/HBASE-3417?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13127018#comment-13127018

Jonathan Gray commented on HBASE-3417:

Stack, I was going to open a new JIRA, but it is the exact same issue and a nearly identical
patch (primary difference is pre/post hfile v2).  It was just incorrect to close this following
commit of hfile v2 which was unrelated to this bug.  Nothing was ever committed under this
JIRA so just reopened with an updated patch.

I think things get confusing when there is more than one commit per branch per jira.  We should
probably ban that practice.  Or at least institute some kind of standardized commit message
(HBASE-3417, HBASE-3417-B, HBASE-3417-C, etc) or some such thing.
> CacheOnWrite is using the temporary output path for block names, need to use a more consistent
block naming scheme
> ------------------------------------------------------------------------------------------------------------------
>                 Key: HBASE-3417
>                 URL: https://issues.apache.org/jira/browse/HBASE-3417
>             Project: HBase
>          Issue Type: Bug
>          Components: io, regionserver
>    Affects Versions: 0.92.0
>            Reporter: Jonathan Gray
>            Assignee: Jonathan Gray
>            Priority: Critical
>             Fix For: 0.92.0
>         Attachments: HBASE-3417-redux-v1.patch, HBASE-3417-v1.patch, HBASE-3417-v2.patch,
> Currently the block names used in the block cache are built using the filesystem path.
 However, for cache on write, the path is a temporary output file.
> The original COW patch actually made some modifications to block naming stuff to make
it more consistent but did not do enough.  Should add a separate method somewhere for generating
block names using some more easily mocked scheme (rather than just raw path as we generate
a random unique file name twice, once for tmp and then again when moved into place).

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message