hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "jiraposter@reviews.apache.org (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-3417) CacheOnWrite is using the temporary output path for block names, need to use a more consistent block naming scheme
Date Thu, 13 Oct 2011 19:37:13 GMT

    [ https://issues.apache.org/jira/browse/HBASE-3417?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13126851#comment-13126851
] 

jiraposter@reviews.apache.org commented on HBASE-3417:
------------------------------------------------------


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/2379/
-----------------------------------------------------------

(Updated 2011-10-13 19:36:33.845621)


Review request for hbase, Dhruba Borthakur, Michael Stack, and Mikhail Bautin.


Changes
-------

Renamed setters to be prefixed with:  forTestsOnly_

(I'm still opting to keep it this way because I know that the next set of tests I write for
the compressed cache stuff is going to want to do the same thing)


Summary
-------

Adds a new test that fails w/o this fix and changes the naming scheme for storefiles to use
UUID instead of random longs as ascii.

The big change is that the name of the tmp file used when flushing and compacting is the same
name (but different dir) when moved in place.  This makes it so block names are consistent
for COW.


This addresses bug HBASE-3417.
    https://issues.apache.org/jira/browse/HBASE-3417


Diffs (updated)
-----

  /src/main/java/org/apache/hadoop/hbase/io/hfile/AbstractHFileWriter.java 1183049 
  /src/main/java/org/apache/hadoop/hbase/io/hfile/CacheConfig.java 1183049 
  /src/main/java/org/apache/hadoop/hbase/regionserver/Store.java 1183049 
  /src/main/java/org/apache/hadoop/hbase/regionserver/StoreFile.java 1183049 
  /src/test/java/org/apache/hadoop/hbase/client/TestFromClientSide.java 1183049 

Diff: https://reviews.apache.org/r/2379/diff


Testing
-------

TestFromClientSide and TestCacheOnWrite both working


Thanks,

Jonathan


                
> CacheOnWrite is using the temporary output path for block names, need to use a more consistent
block naming scheme
> ------------------------------------------------------------------------------------------------------------------
>
>                 Key: HBASE-3417
>                 URL: https://issues.apache.org/jira/browse/HBASE-3417
>             Project: HBase
>          Issue Type: Bug
>          Components: io, regionserver
>    Affects Versions: 0.92.0
>            Reporter: Jonathan Gray
>            Assignee: Jonathan Gray
>            Priority: Critical
>             Fix For: 0.92.0
>
>         Attachments: HBASE-3417-redux-v1.patch, HBASE-3417-v1.patch, HBASE-3417-v2.patch,
HBASE-3417-v5.patch
>
>
> Currently the block names used in the block cache are built using the filesystem path.
 However, for cache on write, the path is a temporary output file.
> The original COW patch actually made some modifications to block naming stuff to make
it more consistent but did not do enough.  Should add a separate method somewhere for generating
block names using some more easily mocked scheme (rather than just raw path as we generate
a random unique file name twice, once for tmp and then again when moved into place).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message