hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Gray (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-3417) CacheOnWrite is using the temporary output path for block names, need to use a more consistent block naming scheme
Date Thu, 13 Oct 2011 22:30:13 GMT

    [ https://issues.apache.org/jira/browse/HBASE-3417?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13127051#comment-13127051
] 

Jonathan Gray commented on HBASE-3417:
--------------------------------------

I didn't mark as incompatible but it is only one-way compatible.

There is actually a very trivial change that can be made in the 0.90 branch (or any other
branches) to make this change compatible in all directions.  Just need to update the REF_NAME_PARSER
regex to be what it is in this change (tolerant of [a-f] in addition to digits).  That's it.
                
> CacheOnWrite is using the temporary output path for block names, need to use a more consistent
block naming scheme
> ------------------------------------------------------------------------------------------------------------------
>
>                 Key: HBASE-3417
>                 URL: https://issues.apache.org/jira/browse/HBASE-3417
>             Project: HBase
>          Issue Type: Bug
>          Components: io, regionserver
>    Affects Versions: 0.92.0
>            Reporter: Jonathan Gray
>            Assignee: Jonathan Gray
>            Priority: Critical
>             Fix For: 0.92.0
>
>         Attachments: HBASE-3417-redux-v1.patch, HBASE-3417-v1.patch, HBASE-3417-v2.patch,
HBASE-3417-v5.patch
>
>
> Currently the block names used in the block cache are built using the filesystem path.
 However, for cache on write, the path is a temporary output file.
> The original COW patch actually made some modifications to block naming stuff to make
it more consistent but did not do enough.  Should add a separate method somewhere for generating
block names using some more easily mocked scheme (rather than just raw path as we generate
a random unique file name twice, once for tmp and then again when moved into place).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message