hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Todd Lipcon (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-3929) Add option to HFile tool to produce basic stats
Date Mon, 17 Oct 2011 17:50:10 GMT

    [ https://issues.apache.org/jira/browse/HBASE-3929?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13129035#comment-13129035

Todd Lipcon commented on HBASE-3929:

Thanks for updating the patch to trunk. A couple of comments (fun to look back over my own
code from a few months back):

- let's rename {{pkv}} to {{prevKV}}
- in the case of an empty HFile, we would currently throw a divide-by-zero. In LongStats.toString,
we should check for count == 0 and return "no data" or something

> Add option to HFile tool to produce basic stats
> -----------------------------------------------
>                 Key: HBASE-3929
>                 URL: https://issues.apache.org/jira/browse/HBASE-3929
>             Project: HBase
>          Issue Type: New Feature
>          Components: io
>    Affects Versions: 0.92.0
>            Reporter: Todd Lipcon
>            Assignee: Todd Lipcon
>             Fix For: 0.94.0
>         Attachments: hbase-3929-draft.patch, hbase-3929-draft.txt
> In looking at HBASE-3421 I wrote a small tool to scan an HFile and produce some basic
statistics about it:
> - min/mean/max key size, value size (uncompressed)
> - min/mean/max number of columns per row (uncompressed)
> - min/mean/max number of bytes per row (uncompressed)
> - the key of the largest row

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message