hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "jiraposter@reviews.apache.org (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-4528) The put operation can release the rowlock before sync-ing the Hlog
Date Sun, 02 Oct 2011 13:59:35 GMT

    [ https://issues.apache.org/jira/browse/HBASE-4528?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13119011#comment-13119011
] 

jiraposter@reviews.apache.org commented on HBASE-4528:
------------------------------------------------------


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/2141/#review2249
-----------------------------------------------------------


Nice feature.
Hopefully there is no surprise in running test suite.


/src/main/java/org/apache/hadoop/hbase/regionserver/HRegion.java
<https://reviews.apache.org/r/2141/#comment5215>

    Better remove the whitespace.



/src/main/java/org/apache/hadoop/hbase/regionserver/HRegion.java
<https://reviews.apache.org/r/2141/#comment5216>

    Thw should be The



/src/main/java/org/apache/hadoop/hbase/regionserver/HRegion.java
<https://reviews.apache.org/r/2141/#comment5217>

    According to the sequence in try block, I think this call should be placed after line
1870.



/src/main/java/org/apache/hadoop/hbase/regionserver/HRegion.java
<https://reviews.apache.org/r/2141/#comment5218>

    There should be javadoc for parameter w.



/src/main/java/org/apache/hadoop/hbase/regionserver/HRegion.java
<https://reviews.apache.org/r/2141/#comment5219>

    Is localizedRwcc a better name ?



/src/test/java/org/apache/hadoop/hbase/regionserver/TestParallelPut.java
<https://reviews.apache.org/r/2141/#comment5220>

    This is no longer needed.



/src/test/java/org/apache/hadoop/hbase/regionserver/TestParallelPut.java
<https://reviews.apache.org/r/2141/#comment5221>

    Should read "don't spin"



/src/test/java/org/apache/hadoop/hbase/regionserver/TestParallelPut.java
<https://reviews.apache.org/r/2141/#comment5222>

    The word test is redundant.



/src/test/java/org/apache/hadoop/hbase/regionserver/TestParallelPut.java
<https://reviews.apache.org/r/2141/#comment5223>

    I think this loop can be folded into the loop above.



/src/test/java/org/apache/hadoop/hbase/regionserver/TestParallelPut.java
<https://reviews.apache.org/r/2141/#comment5224>

    At least a LOG call should be placed here, for debugging.



/src/test/java/org/apache/hadoop/hbase/regionserver/TestParallelPut.java
<https://reviews.apache.org/r/2141/#comment5225>

    Second part of the sentence should be ' see if the values match'.



/src/test/java/org/apache/hadoop/hbase/regionserver/TestParallelPut.java
<https://reviews.apache.org/r/2141/#comment5226>

    Please remove the space before (.



/src/test/java/org/apache/hadoop/hbase/regionserver/TestParallelPut.java
<https://reviews.apache.org/r/2141/#comment5227>

    Should be initHRegion(, without space.



/src/test/java/org/apache/hadoop/hbase/regionserver/TestParallelPut.java
<https://reviews.apache.org/r/2141/#comment5230>

    This variable should be named row or rowkey.



/src/test/java/org/apache/hadoop/hbase/regionserver/TestParallelPut.java
<https://reviews.apache.org/r/2141/#comment5228>

    Good.



/src/test/java/org/apache/hadoop/hbase/regionserver/TestParallelPut.java
<https://reviews.apache.org/r/2141/#comment5229>

    Should append ' + " failed"'


- Ted


On 2011-10-02 07:16:56, Dhruba Borthakur wrote:
bq.  
bq.  -----------------------------------------------------------
bq.  This is an automatically generated e-mail. To reply, visit:
bq.  https://reviews.apache.org/r/2141/
bq.  -----------------------------------------------------------
bq.  
bq.  (Updated 2011-10-02 07:16:56)
bq.  
bq.  
bq.  Review request for hbase.
bq.  
bq.  
bq.  Summary
bq.  -------
bq.  
bq.  The changes the multiPut operation so that the sync to the wal occurs outside the rowlock.
bq.  
bq.  This enhancement is done only to HRegion.mut(Put[]) because this is the only method that
gets invoked from an application. The HRegion.put(Put) is used only by unit tests and should
possibly be deprecated.
bq.  
bq.  I have attached a unit test. I have not yet run all unit tests, but early feedback on
this patch will be very helpful.
bq.  
bq.  
bq.  This addresses bug HBASE-4528.
bq.      https://issues.apache.org/jira/browse/HBASE-4528
bq.  
bq.  
bq.  Diffs
bq.  -----
bq.  
bq.    /src/main/java/org/apache/hadoop/hbase/regionserver/HRegion.java 1178113 
bq.    /src/test/java/org/apache/hadoop/hbase/regionserver/TestParallelPut.java PRE-CREATION

bq.  
bq.  Diff: https://reviews.apache.org/r/2141/diff
bq.  
bq.  
bq.  Testing
bq.  -------
bq.  
bq.  Not yet run the full suite of unit tests.
bq.  
bq.  
bq.  Thanks,
bq.  
bq.  Dhruba
bq.  
bq.


                
> The put operation can release the rowlock before sync-ing the Hlog
> ------------------------------------------------------------------
>
>                 Key: HBASE-4528
>                 URL: https://issues.apache.org/jira/browse/HBASE-4528
>             Project: HBase
>          Issue Type: Improvement
>          Components: regionserver
>            Reporter: dhruba borthakur
>            Assignee: dhruba borthakur
>         Attachments: appendNoSyncPut1.txt
>
>
> This allows for better throughput when there are hot rows. A single row update improves
from 100 puts/sec/server to 5000 puts/sec/server.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message