hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-4494) AvroServer:: get fails with NPE on a non-existent row
Date Wed, 05 Oct 2011 00:09:34 GMT

     [ https://issues.apache.org/jira/browse/HBASE-4494?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

stack updated HBASE-4494:
-------------------------

    Fix Version/s:     (was: 0.90.5)
                   0.92.0

Marking fixed in 0.92.  I applied to 0.92 branch and to TRUNK.  Thanks for the patch Kay Kay.
 In future, we resolve the issue after the patch has been applied.  You can mark its state
as 'patch available' after you've uploaded patch.
                
> AvroServer:: get fails with NPE on a non-existent row
> -----------------------------------------------------
>
>                 Key: HBASE-4494
>                 URL: https://issues.apache.org/jira/browse/HBASE-4494
>             Project: HBase
>          Issue Type: Bug
>          Components: avro
>    Affects Versions: 0.90.4
>            Reporter: Kay Kay
>            Assignee: Kay Kay
>             Fix For: 0.92.0
>
>         Attachments: HBASE-4494.patch
>
>
> Try to submit a get request to the avro gateway. 
> If the row specified for a given table does not exist, the server request fails with
a NPE.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message