hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "jiraposter@reviews.apache.org (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-4507) Create checkAndPut variant that exposes timestamp / UUID
Date Thu, 29 Sep 2011 23:51:46 GMT

    [ https://issues.apache.org/jira/browse/HBASE-4507?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13117753#comment-13117753
] 

jiraposter@reviews.apache.org commented on HBASE-4507:
------------------------------------------------------



bq.  On 2011-09-29 21:54:42, Ted Yu wrote:
bq.  > src/main/java/org/apache/hadoop/hbase/regionserver/HRegion.java, line 1942
bq.  > <https://reviews.apache.org/r/2118/diff/1/?file=46471#file46471line1942>
bq.  >
bq.  >     How about naming this method doTimestampsClash ?

Because I wanted to follow beans convention for naming methods that have boolean return (its
not the best english but tells you more about what to expect of the method than a 'do').


bq.  On 2011-09-29 21:54:42, Ted Yu wrote:
bq.  > src/main/java/org/apache/hadoop/hbase/regionserver/HRegion.java, line 1948
bq.  > <https://reviews.apache.org/r/2118/diff/1/?file=46471#file46471line1948>
bq.  >
bq.  >     I wish there is a better way to handle this situation :-(

This situation is going to be extremely rare.  If it happens at all, we do this +1 on the
ts.  I prefer this to a spin-wait holding up the update.


- Michael


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/2118/#review2176
-----------------------------------------------------------


On 2011-09-29 21:10:29, Michael Stack wrote:
bq.  
bq.  -----------------------------------------------------------
bq.  This is an automatically generated e-mail. To reply, visit:
bq.  https://reviews.apache.org/r/2118/
bq.  -----------------------------------------------------------
bq.  
bq.  (Updated 2011-09-29 21:10:29)
bq.  
bq.  
bq.  Review request for hbase.
bq.  
bq.  
bq.  Summary
bq.  -------
bq.  
bq.  Adds a checkAndPut that takes a timestamp
bq.  
bq.  
bq.  This addresses bug hbase-4507.
bq.      https://issues.apache.org/jira/browse/hbase-4507
bq.  
bq.  
bq.  Diffs
bq.  -----
bq.  
bq.    src/main/java/org/apache/hadoop/hbase/ipc/HRegionInterface.java 3679c02 
bq.    src/main/java/org/apache/hadoop/hbase/regionserver/HRegion.java 7cbdb98 
bq.    src/main/java/org/apache/hadoop/hbase/regionserver/HRegionServer.java 0c06f4f 
bq.    src/test/java/org/apache/hadoop/hbase/regionserver/TestHRegion.java 99b34cc 
bq.  
bq.  Diff: https://reviews.apache.org/r/2118/diff
bq.  
bq.  
bq.  Testing
bq.  -------
bq.  
bq.  
bq.  Thanks,
bq.  
bq.  Michael
bq.  
bq.


                
> Create checkAndPut variant that exposes timestamp / UUID
> --------------------------------------------------------
>
>                 Key: HBASE-4507
>                 URL: https://issues.apache.org/jira/browse/HBASE-4507
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Ted Yu
>            Assignee: stack
>
> Michael checked the checkAndPut which doesn't expose timestamp. A variant of checkAndPut
should be created to expose timestamp which is written into a column specified by additional
parameters.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message