hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lars Hofhansl (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-4296) Deprecate HTable[Interface].getRowOrBefore(...)
Date Fri, 23 Sep 2011 01:01:42 GMT

    [ https://issues.apache.org/jira/browse/HBASE-4296?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13113083#comment-13113083
] 

Lars Hofhansl commented on HBASE-4296:
--------------------------------------

I wonder if we should just rename it to scanMeta or something and force it to work on .Meta.
only.
Then nobody would use it, unless it's used for Meta scanning, and we can then change the implementation.





> Deprecate HTable[Interface].getRowOrBefore(...)
> -----------------------------------------------
>
>                 Key: HBASE-4296
>                 URL: https://issues.apache.org/jira/browse/HBASE-4296
>             Project: HBase
>          Issue Type: Bug
>          Components: client
>    Affects Versions: 0.92.0
>            Reporter: Lars Hofhansl
>            Assignee: Lars Hofhansl
>            Priority: Trivial
>             Fix For: 0.92.0
>
>         Attachments: 4296.txt
>
>
> HTable's getRowOrBefore(...) internally calls into Store.getRowKeyAtOrBefore. That method
was created to allow our scanning of .META. (see HBASE-2600).
> Store.getRowKeyAtOrBefore(...) lists a bunch of requirements for this to be performant
that a user of HTable will not be aware of.
> I propose deprecating this in the public interface in 0.92 and removing it from the public
interface in 0.94. If we don't get to HBASE-2600 in 0.94 it will still remain as internal
interface for scanning meta.
> Comments?

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message