hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Gray (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-4410) FilterList.filterKeyValue can return suboptimal ReturnCodes
Date Sun, 18 Sep 2011 18:24:08 GMT

    [ https://issues.apache.org/jira/browse/HBASE-4410?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13107495#comment-13107495

Jonathan Gray commented on HBASE-4410:

Actually I think Lars is correct.  It's a question of whether we should execute all filters
in a list filterKeyValue() or not.

I think the right behavior is actually just to make it execute how one would expect this type
of conditional to execute:

if (conditionA && conditionB)

If conditionA fails, we don't expect conditionB to be executed.

if (conditionA || conditionB)

If conditionA passes, we don't expect conditionB to be executed.

This was the previous behavior and my patch undoes it.  I will work on a new patch.

> FilterList.filterKeyValue can return suboptimal ReturnCodes
> -----------------------------------------------------------
>                 Key: HBASE-4410
>                 URL: https://issues.apache.org/jira/browse/HBASE-4410
>             Project: HBase
>          Issue Type: Improvement
>          Components: filters
>            Reporter: Jonathan Gray
>            Assignee: Jonathan Gray
>            Priority: Minor
>             Fix For: 0.92.0
>         Attachments: HBASE-4410-v1.patch
> FilterList.filterKeyValue does not always return the most optimal ReturnCode in both
the AND and OR conditions.
> For example, if you have F1 AND F2, F1 returns SKIP.  It immediately returns the SKIP.
 However, if F2 would have returned NEXT_COL or NEXT_ROW or SEEK_NEXT_USING_HINT, we would
actually be able to return the more optimal ReturnCode from F2.
> For AND conditions, we can always pick the *most restrictive* return code.
> For OR conditions, we must always pick the *least restrictive* return code.
> This JIRA is to review the FilterList.filterKeyValue() method to try and make it more
optimal and to add a new unit test which verifies the correct behavior.

This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message