hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joep Rottinghuis (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-4327) Compile HBase against hadoop 0.22
Date Wed, 07 Sep 2011 05:53:10 GMT

     [ https://issues.apache.org/jira/browse/HBASE-4327?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Joep Rottinghuis updated HBASE-4327:
------------------------------------

    Attachment: HBASE-4327.patch

Looks like there is a bug open in Maven to do exactly what I wanted to do:
http://jira.codehaus.org/browse/MNG-3328

What I can do is to change the property to hadoop.profile.
- When nothing is specified, then HBase will build against 0.20
- When -Dhadoop.profile=22 is specified, HBase will build against hadoop 0.22
- When -Dhadoop.profile=23 is specified, HBase will build against hadoop 0.23. This is a change
in behavior, previously used to be -Dhadoop23

Attached a new patch with above behavior. Please let me know if this is acceptable.

> Compile HBase against hadoop 0.22
> ---------------------------------
>
>                 Key: HBASE-4327
>                 URL: https://issues.apache.org/jira/browse/HBASE-4327
>             Project: HBase
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 0.92.0
>            Reporter: Joep Rottinghuis
>             Fix For: 0.92.0
>
>         Attachments: HBASE-4327-Michael.patch, HBASE-4327.patch, HBASE-4327.patch, HBASE-4327.patch
>
>
> Pom contains a profile for hadoop-0.20 and one for hadoop-0.23, but not one for hadoop-0.22.
> When overriding hadoop.version to 0.22, then the (compile-time) dependency on hadoop-annotations
cannot be met.
> That exists on 0.23 and 0.24/trunk, but not on 0.22.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message