hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Gray (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-4451) Improve zk node naming (/hbase/shutdown)
Date Wed, 21 Sep 2011 22:05:27 GMT

    [ https://issues.apache.org/jira/browse/HBASE-4451?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13112155#comment-13112155

Jonathan Gray commented on HBASE-4451:

bq. Would changing this have an effect on compatibility? 

If you wanted to support this change over a rolling restart or anything like that, it would
probably be rather complicated or impractical.  So it would require a full restart of the
cluster most likely.  In addition, any external ops/monitoring/admin tools people have built
might be looking at the specific names.  That shouldn't necessarily stop us though.

Perhaps we can do this as part of a fresh look at the names of the ZK nodes in general.  We
might make some changes with the root node and such as well in 94.  Do you want to look at
all the ZK node names and see if there's a new scheme that would be more clear?

> Improve zk node naming (/hbase/shutdown)
> ----------------------------------------
>                 Key: HBASE-4451
>                 URL: https://issues.apache.org/jira/browse/HBASE-4451
>             Project: HBase
>          Issue Type: Improvement
>          Components: master
>    Affects Versions: 0.94.0
>            Reporter: Harsh J
>            Assignee: Harsh J
>            Priority: Minor
>             Fix For: 0.94.0
> Right now the node {{/hbase/shutdown}} is used to indicate cluster status (cluster up,
cluster down).
> However, upon a chat with Lars George today, we feel that having a name {{/hbase/shutdown}}
is possibly bad. The {{/hbase/shutdown}} zknode contains a date when the cluster was _started_.
Now that is difficult to understand and digest, given that a person may connect to zk and
try to look at what it is about (they may think it 'shutdown' at that date.).
> I feel a better name may simply be: {{/hbase/running}}. Thoughts?

This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message