hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ted Yu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-4240) Allow Loadbalancer to be pluggable.
Date Tue, 23 Aug 2011 01:23:29 GMT

    [ https://issues.apache.org/jira/browse/HBASE-4240?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13089207#comment-13089207

Ted Yu commented on HBASE-4240:

TestLoadBalancer should be named TestDefaultLoadBalancer since factory isn't used to generate
the balancer.

A better name for "hbase.maser.loadBalancer" would be "hbase.maser.loadbalancer.class"

> Allow Loadbalancer to be pluggable.
> -----------------------------------
>                 Key: HBASE-4240
>                 URL: https://issues.apache.org/jira/browse/HBASE-4240
>             Project: HBase
>          Issue Type: New Feature
>          Components: master
>    Affects Versions: 0.94.0
>            Reporter: Elliott Clark
>            Assignee: Elliott Clark
>             Fix For: 0.94.0
>         Attachments: HBASE-4240-0.patch
> Everyone seems to want something different from a load balancer.  People want low latency,
simplicity, and total control.  It seems like at some point the load balancer can't be all
things to all people.  Something akin to what hadoop JT's pluggable scheduler seems like it
will enable all solutions without making the code much more complex. 

This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message