hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HBASE-4156) ZKConfig defaults clientPort improperly
Date Tue, 09 Aug 2011 23:33:27 GMT

     [ https://issues.apache.org/jira/browse/HBASE-4156?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

stack resolved HBASE-4156.
--------------------------

       Resolution: Fixed
    Fix Version/s: 0.92.0
     Hadoop Flags: [Reviewed]

Committed to TRUNK.  Took me a while to understand but makes sense.  Thanks for the patch
Michajlo

> ZKConfig defaults clientPort improperly
> ---------------------------------------
>
>                 Key: HBASE-4156
>                 URL: https://issues.apache.org/jira/browse/HBASE-4156
>             Project: HBase
>          Issue Type: Bug
>          Components: zookeeper
>            Reporter: Michajlo Matijkiw
>            Priority: Trivial
>             Fix For: 0.92.0
>
>         Attachments: clientPort-default-fix.patch
>
>
> ZKConfig#makeZKProps() should use "clientPort" as the client port key in its output when
defaulting instead of "hbase.zookeeper.property.clientPort".  This method strips the "hbase.zookeeper.property."
prefix from all of the properties it returns, so the client port key should not have it. 
The result is that the default is not properly picked up.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message