hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "jiraposter@reviews.apache.org (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-3812) Tidy up naming consistency and documentation in coprocessor framework
Date Mon, 25 Apr 2011 17:33:03 GMT

    [ https://issues.apache.org/jira/browse/HBASE-3812?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13024867#comment-13024867
] 

jiraposter@reviews.apache.org commented on HBASE-3812:
------------------------------------------------------


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/660/#review534
-----------------------------------------------------------

Ship it!


+1 on commit (Minors below to resolve on commit)


src/main/java/org/apache/hadoop/hbase/coprocessor/BaseRegionObserver.java
<https://reviews.apache.org/r/660/#comment1111>

    2011



src/main/java/org/apache/hadoop/hbase/coprocessor/BaseRegionObserver.java
<https://reviews.apache.org/r/660/#comment1112>

    I see RegionObserver but not 'Coprocessor' Is there a CP Interface?



src/main/java/org/apache/hadoop/hbase/coprocessor/BaseRegionObserver.java
<https://reviews.apache.org/r/660/#comment1113>

    you -> your



src/main/java/org/apache/hadoop/hbase/coprocessor/RegionObserver.java
<https://reviews.apache.org/r/660/#comment1114>

    Good



src/test/java/org/apache/hadoop/hbase/coprocessor/TestWALObserver.java
<https://reviews.apache.org/r/660/#comment1115>

    2011


- Michael


On 2011-04-25 17:11:22, Mingjie Lai wrote:
bq.  
bq.  -----------------------------------------------------------
bq.  This is an automatically generated e-mail. To reply, visit:
bq.  https://reviews.apache.org/r/660/
bq.  -----------------------------------------------------------
bq.  
bq.  (Updated 2011-04-25 17:11:22)
bq.  
bq.  
bq.  Review request for hbase and Gary Helmling.
bq.  
bq.  
bq.  Summary
bq.  -------
bq.  
bq.  As described at hbase-3812:
bq.  * rename BaseRegionObserverCoprocessor -> BaseRegionObserver
bq.  * in BaseMasterObserver, rename ObserverContext parameter variable from "env" to "c"
or "ctx"
bq.  * unnecessary public modifier for methods in RegionObserver interface
bq.  
bq.  
bq.  This addresses bug hbase-3812.
bq.      https://issues.apache.org/jira/browse/hbase-3812
bq.  
bq.  
bq.  Diffs
bq.  -----
bq.  
bq.    src/main/java/org/apache/hadoop/hbase/coprocessor/BaseMasterObserver.java 8df6aa4 
bq.    src/main/java/org/apache/hadoop/hbase/coprocessor/BaseRegionObserver.java PRE-CREATION

bq.    src/main/java/org/apache/hadoop/hbase/coprocessor/BaseRegionObserverCoprocessor.java
a8c7cb2 
bq.    src/main/java/org/apache/hadoop/hbase/coprocessor/RegionObserver.java 5c5d18d 
bq.    src/test/java/org/apache/hadoop/hbase/coprocessor/SampleRegionWALObserver.java c1fe58d

bq.    src/test/java/org/apache/hadoop/hbase/coprocessor/SimpleRegionObserver.java e201b3f

bq.    src/test/java/org/apache/hadoop/hbase/coprocessor/TestCoprocessorInterface.java 0a07e03

bq.    src/test/java/org/apache/hadoop/hbase/coprocessor/TestRegionObserverStacking.java 20a8d7d

bq.    src/test/java/org/apache/hadoop/hbase/coprocessor/TestWALCoprocessors.java 27c38f9

bq.    src/test/java/org/apache/hadoop/hbase/coprocessor/TestWALObserver.java PRE-CREATION

bq.  
bq.  Diff: https://reviews.apache.org/r/660/diff
bq.  
bq.  
bq.  Testing
bq.  -------
bq.  
bq.  Tests passed locally.
bq.  
bq.  
bq.  Thanks,
bq.  
bq.  Mingjie
bq.  
bq.



> Tidy up naming consistency and documentation in coprocessor framework
> ---------------------------------------------------------------------
>
>                 Key: HBASE-3812
>                 URL: https://issues.apache.org/jira/browse/HBASE-3812
>             Project: HBase
>          Issue Type: Improvement
>          Components: coprocessors
>            Reporter: Gary Helmling
>            Priority: Critical
>             Fix For: 0.92.0
>
>
> We have a few naming inconsistencies in the coprocessor API and some stale javadocs that
have been spotted by Lars George as he digs through it.  We should clean these up before we
have an official release and are forced to go through a round of deprecation to make any changes.
> Current items on the list:
>  * rename BaseRegionObserverCoprocessor -> BaseRegionObserver
>  * in BaseMasterObserver, rename ObserverContext parameter variable from "env" to "c"
or "ctx"
>  * unnecessary public modifier for methods in RegionObserver interface
> As part of this, we should take a pass through the javadocs and verify they are up to
date with what is currently implemented.
> Please tack on other cosmetic changes or inconsistencies as you find them.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message