hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HBASE-3812) Tidy up naming consistency and documentation in coprocessor framework
Date Mon, 25 Apr 2011 19:23:03 GMT

     [ https://issues.apache.org/jira/browse/HBASE-3812?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

stack resolved HBASE-3812.

      Resolution: Fixed
    Hadoop Flags: [Reviewed]

Committed to trunk.  Thanks for the patch Mingjie.

> Tidy up naming consistency and documentation in coprocessor framework
> ---------------------------------------------------------------------
>                 Key: HBASE-3812
>                 URL: https://issues.apache.org/jira/browse/HBASE-3812
>             Project: HBase
>          Issue Type: Improvement
>          Components: coprocessors
>            Reporter: Gary Helmling
>            Assignee: Mingjie Lai
>            Priority: Critical
>             Fix For: 0.92.0
> We have a few naming inconsistencies in the coprocessor API and some stale javadocs that
have been spotted by Lars George as he digs through it.  We should clean these up before we
have an official release and are forced to go through a round of deprecation to make any changes.
> Current items on the list:
>  * rename BaseRegionObserverCoprocessor -> BaseRegionObserver
>  * in BaseMasterObserver, rename ObserverContext parameter variable from "env" to "c"
or "ctx"
>  * unnecessary public modifier for methods in RegionObserver interface
> As part of this, we should take a pass through the javadocs and verify they are up to
date with what is currently implemented.
> Please tack on other cosmetic changes or inconsistencies as you find them.

This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message