hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (HBASE-3600) Update our jruby to 1.6.0
Date Tue, 15 Mar 2011 23:19:29 GMT

     [ https://issues.apache.org/jira/browse/HBASE-3600?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

stack resolved HBASE-3600.
--------------------------

       Resolution: Fixed
    Fix Version/s:     (was: 0.92.0)
                   0.90.2
         Assignee: stack

Updated our jruby on trunk and branch (Did it on branch because parser is much better in newer
jruby giving better errors which scripting -- throws more explanatory exceptions too).

> Update our jruby to 1.6.0
> -------------------------
>
>                 Key: HBASE-3600
>                 URL: https://issues.apache.org/jira/browse/HBASE-3600
>             Project: HBase
>          Issue Type: Task
>            Reporter: stack
>            Assignee: stack
>             Fix For: 0.90.2
>
>
> We reverted our jruby jar to 1.0.3 because of licensing issues in 1.5.x.  The jruby crew
fixed the licensing issues in 1.6.0RC2 (which is released but not yet in a mvn repo).  This
issue is about updating our ruby.  The old ruby 'works' but is bad in many ways; bad parse
errors, missing language support that made us redo a bunch of our script to not use import
(and removal of TestShell, our unit test that ran jruby tests).
> This issue is about updating our jruby and in particular, reenabling the TestShell unit
test removed by HBASE-3374.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message