hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Todd Lipcon (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (HBASE-3470) Check that hbase-default.xml is loaded from within jar
Date Mon, 07 Feb 2011 20:30:57 GMT

     [ https://issues.apache.org/jira/browse/HBASE-3470?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Todd Lipcon resolved HBASE-3470.
--------------------------------

      Resolution: Fixed
    Hadoop Flags: [Reviewed]

Committed to branch and trunk. Amended the error message as suggested by Stack.

> Check that hbase-default.xml is loaded from within jar
> ------------------------------------------------------
>
>                 Key: HBASE-3470
>                 URL: https://issues.apache.org/jira/browse/HBASE-3470
>             Project: HBase
>          Issue Type: Improvement
>    Affects Versions: 0.90.1
>            Reporter: Todd Lipcon
>            Assignee: Todd Lipcon
>             Fix For: 0.90.1
>
>         Attachments: hbase-3470.txt
>
>
> Running hbase with an old version of hbase-default.xml on the classpath (as might happen
when upgrading from 0.20 where it wasn't in the jar) can cause lots of strange problems. We
should add a check at startup time that ensures that the hbase-default.xml file is coming
out of the jar rather than somewhere on the classpath.

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message