hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HBASE-3431) Regionserver is not using the name given it by the master; double entry in master listing of servers
Date Tue, 11 Jan 2011 07:21:46 GMT

     [ https://issues.apache.org/jira/browse/HBASE-3431?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

stack updated HBASE-3431:
-------------------------

    Attachment: 3431.txt

A unit test that has master setting an address for the regionserver to use and then verifying
that subsequently the regionserver volunteers what we told it use.  Passes on TRUNK which
would seem to say this stuff should be working fine.

I compared 0.89 and 0.90 HRS.  Nothing jumps out.

> Regionserver is not using the name given it by the master; double entry in master listing
of servers
> ----------------------------------------------------------------------------------------------------
>
>                 Key: HBASE-3431
>                 URL: https://issues.apache.org/jira/browse/HBASE-3431
>             Project: HBase
>          Issue Type: Bug
>    Affects Versions: 0.90.0
>            Reporter: stack
>         Attachments: 3431.txt
>
>
> Our man Ted Dunning found the following where RS checks in with one name, the master
tells it use another name but we seem to go ahead and continue with our original name.
> In RS logs I see:
> {code}
> 2011-01-07 15:45:50,757 INFO  org.apache.hadoop.hbase.regionserver.HRegionServer [regionserver60020]:
Master passed us address to use. Was=perfnode11:60020, Now=10.10.30.11:60020
> {code}
> On master I see
> {code}
> 2011-01-07 15:45:38,613 INFO  org.apache.hadoop.hbase.master.ServerManager [IPC Server
handler 0 on 60000]: Registering server=10.10.30.11,60020,1294443935414, regionCount=0, userLoad=false
> {code}
> ....
> then later
> {code}
> 2011-01-07 15:45:44,247 INFO  org.apache.hadoop.hbase.master.ServerManager [IPC Server
handler 2 on 60000]: Registering server=perfnode11,60020,1294443935414, regionCount=0, userLoad=true
> {code}
> This might be since we started letting servers register in other than with the reportStartup.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message