hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Gray (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HBASE-3417) CacheOnWrite is using the temporary output path for block names, need to use a more consistent block naming scheme
Date Thu, 06 Jan 2011 18:10:45 GMT

    [ https://issues.apache.org/jira/browse/HBASE-3417?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12978431#action_12978431

Jonathan Gray commented on HBASE-3417:

bq. Should you add in A-Z in below just in case?
Could add A-F (uuid is hex chars only), but it's unnecessary.

bq. Then its easy to go back to UUID. You might want to do that so you can use the 128 bits
as key in LRU rather than String?
LRU uses a String for block name.  I think it looks much nicer with a consistent looking naming
scheme for region directories and storefiles.  And I don't think we need to be overly concerned
about the size... If 64K block, in the LRU we're talking about 0.05% overhead (or like 0.02%
over a more compact version).

Also, traditional GUID format reminds me of Microsoft SQL Server :)

This latest v5 patch is being deployed on a 100 node cluster with existing data tonight. 
Will commit once verified that it's working there.

> CacheOnWrite is using the temporary output path for block names, need to use a more consistent
block naming scheme
> ------------------------------------------------------------------------------------------------------------------
>                 Key: HBASE-3417
>                 URL: https://issues.apache.org/jira/browse/HBASE-3417
>             Project: HBase
>          Issue Type: Bug
>          Components: io, regionserver
>    Affects Versions: 0.92.0
>            Reporter: Jonathan Gray
>            Assignee: Jonathan Gray
>            Priority: Critical
>             Fix For: 0.92.0
>         Attachments: HBASE-3417-v1.patch, HBASE-3417-v2.patch, HBASE-3417-v5.patch
> Currently the block names used in the block cache are built using the filesystem path.
 However, for cache on write, the path is a temporary output file.
> The original COW patch actually made some modifications to block naming stuff to make
it more consistent but did not do enough.  Should add a separate method somewhere for generating
block names using some more easily mocked scheme (rather than just raw path as we generate
a random unique file name twice, once for tmp and then again when moved into place).

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message