hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (HBASE-3194) HBase should run on both secure and vanilla versions of Hadoop 0.20
Date Tue, 09 Nov 2010 05:45:22 GMT

     [ https://issues.apache.org/jira/browse/HBASE-3194?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

stack resolved HBASE-3194.
--------------------------

      Resolution: Fixed
        Assignee: Gary Helmling
    Hadoop Flags: [Reviewed]

Committed.  Thanks for the patch Gary.

> HBase should run on both secure and vanilla versions of Hadoop 0.20
> -------------------------------------------------------------------
>
>                 Key: HBASE-3194
>                 URL: https://issues.apache.org/jira/browse/HBASE-3194
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Gary Helmling
>            Assignee: Gary Helmling
>             Fix For: 0.90.0
>
>
> There have been a couple cases recently of folks trying to run HBase trunk (or 0.89 DRs)
on CDH3b3 or secure Hadoop.    While HBase security is in the works, it currently only runs
on secure Hadoop versions.  Meanwhile HBase trunk won't compile on secure Hadoop due to backward
incompatible changes in org.apache.hadoop.security.UserGroupInformation.
> This issue is to work out the minimal set of changes necessary to allow HBase to build
and run on both secure and non-secure versions of Hadoop.  Though, with secure Hadoop, I don't
even think it's important to target running with HDFS security enabled (and krb authentication).
 Just allow HBase to build and run in both versions.
> I think mainly this amounts to abstracting usage of UserGroupInformation and UnixUserGroupInformation.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message