hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HBASE-3184) Xmx setting in pom to use for tests/surefire does not appear to work
Date Mon, 01 Nov 2010 19:16:23 GMT

    [ https://issues.apache.org/jira/browse/HBASE-3184?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12927097#action_12927097
] 

stack commented on HBASE-3184:
------------------------------

I tried quoting it on linux -- bad.  I tried this patch on linux and good.

Forking command line: /bin/sh -c cd /home/stack/hbase && /usr/lib/jvm/java-6-sun-1.6.0.22/jre/bin/java
-enableassertions -Xmx1400m -jar /tmp/surefirebooter9055735266082879429.jar /tmp/surefire849494456353668359tmp
/tmp/surefire1318869691288010370tmp

Tried it on mac too....

Forking command line: /bin/sh -c cd /Users/stack/checkouts/trunk && /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/bin/java
-enableassertions -Xmx1400m -jar /var/folders/fm/fmAR6VZ1HTChC80jm2Twmk+++TI/-Tmp-/surefirebooter7770704693040280207.jar
/var/folders/fm/fmAR6VZ1HTChC80jm2Twmk+++TI/-Tmp-/surefire1484449681591552372tmp /var/folders/fm/fmAR6VZ1HTChC80jm2Twmk+++TI/-Tmp-/surefire3760098851031822449tmp


+1 on commit.

> Xmx setting in pom to use for tests/surefire does not appear to work
> --------------------------------------------------------------------
>
>                 Key: HBASE-3184
>                 URL: https://issues.apache.org/jira/browse/HBASE-3184
>             Project: HBase
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 0.90.0
>            Reporter: Jonathan Gray
>             Fix For: 0.90.0
>
>         Attachments: HBASE-3184-v1.patch
>
>
> I was running intense version of TestRollingRestart and changing the Xmx setting in our
pom file wasn't changing anything.
> What we have now is:
> {noformat}
>             <argLine>-enableassertions</argLine>
>             <argLine>-Xmx1400m</argLine>
> {noformat}
> But on process listing (and through experimentation with my tests), only -enableassertions
is used.
> However, changing to below and it worked:
> {noformat}
>             <argLine>-enableassertions -Xmx1400m</argLine>
> {noformat}
> Just wanted to open a jira and see if i'm missing something from someone with more maven
experience.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message