hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "HBase Review Board (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HBASE-2253) Show Block cache hit ratio for requests where cacheBlocks=true
Date Sat, 30 Oct 2010 04:34:20 GMT

    [ https://issues.apache.org/jira/browse/HBASE-2253?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12926536#action_12926536

HBase Review Board commented on HBASE-2253:

Message from: stack@duboce.net

This is an automatically generated e-mail. To reply, visit:

Ship it!

This is fine to commit but only after these new params have gotten more documentation.  Its
not easy discern what hitCachingCount refers too (There is also a question of whether these
variables are properly named -- see what you think).  But I'm good to commit with these varnames
as long as they get docing around their declaration in particular.


    These need documentation.  Should these be called hitCacheCount rather than hitCachingCount?

- stack

> Show Block cache hit ratio for requests where cacheBlocks=true
> --------------------------------------------------------------
>                 Key: HBASE-2253
>                 URL: https://issues.apache.org/jira/browse/HBASE-2253
>             Project: HBase
>          Issue Type: Improvement
>            Reporter: Dave Latham
>            Assignee: Jonathan Gray
>            Priority: Minor
>             Fix For: 0.90.0
> We've been disabling block caching for MR jobs and other big scans.  It seems to improve
cache performance, but it's difficult to measure the hit ratio because even scans that don't
cache blocks still request blocks from the cache (which is good), and those requests affect
the hit/miss stats, which makes it difficult to see how the queries where cacheBlocks=true
are performing.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message