hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "HBase Review Board (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HBASE-2993) Refactor servers to use a common lifecycle interface
Date Tue, 14 Sep 2010 02:01:32 GMT

    [ https://issues.apache.org/jira/browse/HBASE-2993?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12909091#action_12909091

HBase Review Board commented on HBASE-2993:

Message from: "Jonathan Gray" <jgray@apache.org>

This is an automatically generated e-mail. To reply, visit:

I like this.  Naming seems fine to me.  We're making great strides in cleaning these things
up, great stuff Todd.

I guess we're in need of standardizing the methods in HM and HRS like toString, get*Name,


    The toString() is supposed to give a unique name for the instance, especially useful in
unit tests with multiple masters and such.  Not sure where all we're using getServerName but
might make sense for these to be the same.

- Jonathan

> Refactor servers to use a common lifecycle interface
> ----------------------------------------------------
>                 Key: HBASE-2993
>                 URL: https://issues.apache.org/jira/browse/HBASE-2993
>             Project: HBase
>          Issue Type: Improvement
>          Components: master, regionserver
>    Affects Versions: 0.90.0
>            Reporter: Todd Lipcon
>            Assignee: Todd Lipcon
> In current trunk, the region server is a Runnable and the Master is a thread. We have
all kinds of weird wrappers like JVMClusterUtil to try to work around this. It would be nice
if they both implemented the same interface - LocalHBaseCluster and the MiniCluster would
be a lot easier to understand as well, and we could share some more code between them.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message