hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HBASE-2773) HBaseTestingUtility should check against missing CATALOG_FAMILY data in getMetaTableRows
Date Fri, 16 Jul 2010 22:56:49 GMT

    [ https://issues.apache.org/jira/browse/HBASE-2773?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12889381#action_12889381
] 

stack commented on HBASE-2773:
------------------------------

.bq You don't think this is masking some other bug? ie is it normal/expected to see empty
row there in any circumstance?

Ignoring null, I do think it  masking some failure.  The basescanner does something similar.
 If HRI is empty, it'll empty the server and startcode.  This was added way back because couldn't
figure why it was happening (seems extremely rare these days) and yes, we should get to the
root of it.

> HBaseTestingUtility should check against missing CATALOG_FAMILY data in getMetaTableRows
> ----------------------------------------------------------------------------------------
>
>                 Key: HBASE-2773
>                 URL: https://issues.apache.org/jira/browse/HBASE-2773
>             Project: HBase
>          Issue Type: Bug
>          Components: test
>    Affects Versions: 0.90.0
>            Reporter: Todd Lipcon
>            Assignee: Todd Lipcon
>            Priority: Minor
>             Fix For: 0.90.0
>
>         Attachments: hbase-2773.txt
>
>
> I had some failed test due to this last weekend, but can't find the trace now.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message