hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HBASE-2703) ui not working in distributed context
Date Tue, 08 Jun 2010 23:46:11 GMT

     [ https://issues.apache.org/jira/browse/HBASE-2703?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

stack updated HBASE-2703:
-------------------------

    Attachment: 2703.txt

This patch seems to fix it. Main change is this in bin/hbase:

{code}
@@ -158,11 +158,15 @@ fi

 # For releases, add hbase & webapps to CLASSPATH
 # Webapps must come first else it messes up Jetty
-if [ -d "$HBASE_HOME/webapps" ]; then
+if [ -d "$HBASE_HOME/hbase-webapps" ]; then
   CLASSPATH=${CLASSPATH}:$HBASE_HOME
 fi
 for f in $HBASE_HOME/hbase*.jar; do
-  if [ -f $f ]; then
+  if [[ $f = *sources.jar ]]
+  then
+    : # Skip sources.jar
+  elif [ -f $f ]
+  then
     CLASSPATH=${CLASSPATH}:$f;
   fi
 done
{code}

The first change seems to fix it.  The second gets rid of a needless unjarring that was going
on because sources has jsp in it.

I'm still at this.  I might add a bit more to the patch.  It looks like WEB-INF/web.xml is
being generated into our src/main/resources...  rather than under target/.....  Will try fix
that while in here. 

> ui not working in distributed context
> -------------------------------------
>
>                 Key: HBASE-2703
>                 URL: https://issues.apache.org/jira/browse/HBASE-2703
>             Project: HBase
>          Issue Type: Bug
>            Reporter: stack
>             Fix For: 0.21.0
>
>         Attachments: 2703.txt
>
>
> UI is not showing when you put hbase on a cluster; this is since we renamed webapps dir
as hbase-webapps.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message