hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HBASE-2489) Make the "Filesystem needs to be upgraded" error message more useful.
Date Tue, 27 Apr 2010 00:27:35 GMT

    [ https://issues.apache.org/jira/browse/HBASE-2489?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12861185#action_12861185
] 

stack commented on HBASE-2489:
------------------------------

The Migrate.java got removed as part of the cleanup of TRUNK removing deprecated stuff:

{code}
------------------------------------------------------------------------
r816014 | jgray | 2009-09-16 16:59:51 -0700 (Wed, 16 Sep 2009) | 1 line

HBASE-1822  Remove the deprecated APIs (incompatible change)
{code}

My guess is that the thought was that a new Migrate would be made when we had something to
actually Migrate.

The removal of the Migrate class may have been a bit of over-enthusiastic pruning but we can
probably live with things as they currently are until a 0.21 version of hbase.

@Benoit: I could commit this patch as is and we address improving the 'null' message in another
issue?

> Make the "Filesystem needs to be upgraded" error message more useful.
> ---------------------------------------------------------------------
>
>                 Key: HBASE-2489
>                 URL: https://issues.apache.org/jira/browse/HBASE-2489
>             Project: Hadoop HBase
>          Issue Type: Improvement
>          Components: util
>            Reporter: Benoit Sigoure
>            Assignee: Benoit Sigoure
>            Priority: Trivial
>         Attachments: 0001-Improve-the-error-message-File-system-needs-to-be-up.patch
>
>
> The other day, when starting HBase I got this error:
> {noformat}
> 2010-04-23 09:38:14,847 ERROR org.apache.hadoop.hbase.master.HMaster: Failed to start
master
> org.apache.hadoop.hbase.util.FileSystemVersionException: File system needs to be upgraded.
Run the '${HBASE_HOME}/bin/hbase migrate' script.
>         at org.apache.hadoop.hbase.util.FSUtils.checkVersion(FSUtils.java:187)
> {noformat}
> I was puzzled until I realized, after adding extra debug statements in the code, that
I forgot to properly set {{hbase.rootdir}} after re-deploying my dev environment.  I think
the message above was misleading and I'm proposing a trivial patch to make it a little bit
better:
> {noformat}
> 2010-04-23 09:48:29,000 ERROR org.apache.hadoop.hbase.master.HMaster: Failed to start
master
> org.apache.hadoop.hbase.util.FileSystemVersionException: File system needs to be upgraded.
 You have version null and I want version 7.  Run the '${HBASE_HOME}/bin/hbase migrate' script.
>         at org.apache.hadoop.hbase.util.FSUtils.checkVersion(FSUtils.java:189)
> {noformat}

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message