hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 张铎(Duo Zhang) <palomino...@gmail.com>
Subject Re: [CANCEL] [VOTE] The first HBase 1.4.10 release candidate (RC0) is available
Date Sun, 12 May 2019 12:36:23 GMT
Already filed HBASE-22399 for this, but the first plan is to upgrade to
2.8.5, I think by default we should use the lowest supported minor release
line? We could move up to 2.9.x later if 2.8.x is also EOL in newer minor
releases.

Andrew Purtell <andrew.purtell@gmail.com> 于2019年5月12日周日 下午5:35写道:

> I commented on the JIRA. I think there is plenty of time to address this
> with an addendum commit.
>
> For branch-1.4 support for all of 2.7.x is important but for branch-1
> isn’t 2.7 now EOL?
>
> Should we update the default build version for branch-1 and any 1.5 and up
> to 2.9? Latest is 2.9.2 I believe. By commit history this is the most
> active 2.x releasing line. 2.8 is seeing occasional update too, but it is
> not likely to live as long as 2.9 is my guess. If this is the decision then
> no change is needed for branch-1 for the 22048 issue except a change to the
> Hadoop version support matrix.
>
>
> > On May 11, 2019, at 11:33 PM, 张铎(Duo Zhang) <palomino219@gmail.com>
> wrote:
> >
> > Please see the last few comments on HBASE-21048, we breaks the compile
> with
> > hadoop-2.7.1 and hadoop-2.7.2. We need to address it before RC1 I think.
> >
> > Andrew Purtell <andrew.purtell@gmail.com> 于2019年5月12日周日 上午9:23写道:
> >
> >> After one week with only one -1 vote it is my estimation this vote has
> >> failed and so this RC is withdrawn.
> >>
> >>> On May 3, 2019, at 6:04 PM, Andrew Purtell <apurtell@apache.org>
> wrote:
> >>>
> >>> The first HBase 1.4.10 release candidate (RC0) is available for
> download
> >> at https://dist.apache.org/repos/dist/dev/hbase/hbase-1.4.10RC0/ and
> >> Maven artifacts are available in the temporary repository
> >> https://repository.apache.org/content/repositories/orgapachehbase-1310
> .
> >>>
> >>> The git tag corresponding to the candidate is '1.4.10RC0' (8a597e477e).
> >>>
> >>> A detailed source and binary compatibility report for this release is
> >> available for your review at
> >>
> https://dist.apache.org/repos/dist/dev/hbase/hbase-1.4.10RC0/compat-check-report.html
> >> . There are no reported compatibility issues of concern. The changes to
> >> Public annotated class MultiRowRangeFilter are reported as low impact by
> >> the compatibility checker tool and were discussed and allowed on
> >> HBASE-22215.
> >>>
> >>> A list of the 57 issues resolved in this release can be found at
> >> https://s.apache.org/7gSD .
> >>>
> >>> Please try out the candidate and vote +1/0/-1.
> >>>
> >>> The vote will be open for at least 72 hours. Unless objection I will
> try
> >> to close it Friday May 19, 2019 if we have sufficient votes.
> >>>
> >>> Prior to making this announcement I made the following preflight
> checks:
> >>>
> >>>    RAT check passes (7u80)
> >>>    Unit test suite passes 5/5 (7u80, 8u172)
> >>>    LTT load 100M rows with 100% verification and 20% updates (8u181)
> >>>
> >>>
> >>> --
> >>> Best regards,
> >>> Andrew
> >>>
> >>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message