hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-19742) TestMemstoreLABWithoutPool fails on some machines
Date Tue, 09 Jan 2018 22:30:00 GMT
stack created HBASE-19742:
-----------------------------

             Summary: TestMemstoreLABWithoutPool fails on some machines
                 Key: HBASE-19742
                 URL: https://issues.apache.org/jira/browse/HBASE-19742
             Project: HBase
          Issue Type: Bug
          Components: test
            Reporter: stack


On Andrew Purtell's linux he sees this when he runs TestMemstoreLABWithoutPool (See thread
"[VOTE] The second hbase-2.0.0-beta-1 Release Candidate is available for download"):

{code}
TestMemstoreLABWithoutPool.org.apache.hadoop.hbase.regionserver.TestMemstoreLABWithoutPool
can fail with OOME if not run in isolation.

If run in isolation, I get

org.apache.hadoop.hbase.regionserver.TestMemstoreLABWithoutPool.testLABChunkQueueWithMultipleMSLABs(org.apache.hadoop.hbase.regionserver.TestMemstoreLABWithoutPool)
[ERROR]   Run 1:
TestMemstoreLABWithoutPool.testLABChunkQueueWithMultipleMSLABs:143 All the
chunks must have been cleared
[ERROR]   Run 2:
TestMemstoreLABWithoutPool.testLABChunkQueueWithMultipleMSLABs:143 All the
chunks must have been cleared
[ERROR]   Run 3:
TestMemstoreLABWithoutPool.testLABChunkQueueWithMultipleMSLABs:143 All the
chunks must have been cleared
[ERROR]   Run 4:
TestMemstoreLABWithoutPool.testLABChunkQueueWithMultipleMSLABs:143 All the
chunks must have been cleared
{code}

It runs fine for me on my linux and mac. [~ram_krish] / [~anastas] ? You see any of this?

Going to disable this test in meantime.... in subissue.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message