hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nick Dimiduk <ndimi...@gmail.com>
Subject Re: DISCUSSION: Minimum hbase1 version from which you can upgrade to hbase2 (1.2.x?)
Date Sat, 04 Nov 2017 03:25:05 GMT
1.2 is good, but are we aware of anything that precludes 1.1? 0.98? On disk
compatibility (HFile, WAL, AMv2) should be the limiting factor here, right?
Wire protocols have been compatible all the while...

On Fri, Nov 3, 2017 at 5:56 PM Zach York <zyork.contribution@gmail.com>
wrote:

> +1 for having the minimum (supported) hbase1 version be 1.2.x.
>
> On Fri, Nov 3, 2017 at 5:30 PM, Stack <stack@duboce.net> wrote:
>
> > Over in the adjacent "[DISCUSS] hbase-2.0.0 compatibility expectations"
> > thread, we chatted some on what would be the minimum hbase-1.x version
> from
> > which you can upgrade to hbase-2.
> >
> > The last statement made on this topic by Sean was that only upgrades from
> > 1.2.x, our current stable offering, or later should be supported.
> >
> > There was no dissent.
> >
> > We all good w/ this? Speak up if you disagree else 1.2.x becomes the
> > 'official' minimum.
> >
> > NOTES:
> >
> > + We need to agree on a minimum so we know what migrations to test.
> > + It might be possible to upgrade from versions before 1.2.x but we (or
> at
> > least I -- smile) won't have tried it or run verifications to ensure all
> > made it over (let us know if you successfully migrate from a baseline
> that
> > precedes 1.2).
> > + Hopefully we can avoid requiring Users move to the latest on the 1.2
> > branch. This shouldn't be necessary doing a stop/start upgrade. It might
> be
> > needed doing a rolling upgrade. Lets see.
> >
> > Thanks,
> > St.Ack
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message