hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Busbey <bus...@apache.org>
Subject Re: HBase Precommit docker failure
Date Sat, 04 Nov 2017 03:54:53 GMT
It looks like you've already found and cherry-picked back the latest
docker image changes. Is there a JIRA where you're tracking the issue
and I can chime in?

On Fri, Nov 3, 2017 at 8:30 PM, Zach York <zyork.contribution@gmail.com> wrote:
> Trying again.
>
> I wonder if it might be differences between master and the feature branch:
> https://github.com/apache/hbase/tree/HBASE-18477.
>
> On Fri, Nov 3, 2017 at 5:59 PM, Ted Yu <yuzhihong@gmail.com> wrote:
>
>> The issue doesn't seem to be related to H9.
>>
>> See this recent QA run which ran on H9:
>> https://builds.apache.org/job/PreCommit-HBASE-Build/9596/console
>>
>> Have you triggered another QA run ?
>>
>> On Fri, Nov 3, 2017 at 5:55 PM, Zach York <zyork.contribution@gmail.com>
>> wrote:
>>
>> > Hello,
>> >
>> > I had a failure in https://builds.apache.org/job/
>> > PreCommit-HBASE-Build/9600
>> > due to a failure to build the docker image on H9. Is this something that
>> > usually just needs to be retried or does this point to a more serious
>> > issue? I'm new to the HBase jenkins world :)
>> >
>> > *00:44:55* Building native extensions.  This could take a
>> > while...*00:44:56*  [91mERROR:  Error installing rubocop:*00:44:56*
>> >         rubocop requires Ruby version >= 2.1.0.*00:44:56*
>> [0mSuccessfully
>> > installed rainbow-2.2.2*00:44:56* Successfully installed
>> > ruby-progressbar-1.9.0*00:44:56* Successfully installed
>> > unicode-display_width-1.3.0*00:44:57* The command '/bin/sh -c gem
>> > install rubocop' returned a non-zero code: 1*00:44:57* *00:44:57*
>> > Total Elapsed time:  20m  8s*00:44:57* *00:44:57* ERROR: Docker failed
>> > to build image.
>> >
>> > Thanks,
>> >
>> > Zach
>> >
>>

Mime
View raw message