hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sean Busbey <bus...@apache.org>
Subject Re: Hadoop QA failed to build in branch-1 & branch-1.3
Date Sat, 27 May 2017 19:14:19 GMT
Also, this is specifically when the per-branch docker image is
attempting to install the jdk(s) that are appropriate for the given
branch.

like branch-1 that is mentioned above is here:

https://github.com/apache/hbase/blob/branch-1/dev-support/docker/Dockerfile

On Sat, May 27, 2017 at 2:10 PM, Sean Busbey <busbey@apache.org> wrote:
> Dima, the issue pointed out above is specific to the branch-1*
> branches that do support java 7. the master branch already doesn't do
> any java 7, which is why the failures don't happen on it.
>
> On Sat, May 27, 2017 at 11:58 AM, Dima Spivak <dimaspivak@apache.org> wrote:
>> Hey there,
>>
>> The master branch actually doesn't support Java 7 at all, so we should
>> remove that; good catch. Would you mind opening a JIRA for the issue and
>> one of the members of the team with Jenkins access can address it?
>>
>> On Sat, May 27, 2017 at 3:18 AM OpenInx <openinx@gmail.com> wrote:
>>
>>> Hi Guys
>>>
>>> Seems like we always fail to install jdk7 for Hadoop QA currently. ( RUN
>>> apt-get -q update && apt-get -q install -y oracle-java7-installer failed)
>>>
>>> I'm not familiar with Hadoop QA environment,   Could anyone help to (or
>>> tell how to)  fix it ?
>>>
>>> 1.  https://builds.apache.org/job/PreCommit-HBASE-Build/6921/console
>>> 2.  https://builds.apache.org/job/PreCommit-HBASE-Build/6960/console
>>> 3.  https://issues.apache.org/jira/browse/HBASE-18066?
>>> focusedCommentId=16025718&page=com.atlassian.jira.
>>> plugin.system.issuetabpanels:comment-tabpanel#comment-16025718
>>>
>>>
>>> Thanks.
>>>
>> --
>> -Dima

Mime
View raw message