hbase-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chia-Ping Tsai (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (HBASE-15583) Any HTableDescriptor we give out should be immutable
Date Wed, 26 Apr 2017 19:32:04 GMT

     [ https://issues.apache.org/jira/browse/HBASE-15583?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Chia-Ping Tsai resolved HBASE-15583.
------------------------------------
    Resolution: Fixed

The "rebased" code is some hunks. Thanks for the reviewing. [~yuzhihong@gmail.com], [~stack]

> Any HTableDescriptor we give out should be immutable
> ----------------------------------------------------
>
>                 Key: HBASE-15583
>                 URL: https://issues.apache.org/jira/browse/HBASE-15583
>             Project: HBase
>          Issue Type: Sub-task
>    Affects Versions: 2.0.0
>            Reporter: Gabor Liptak
>            Assignee: Chia-Ping Tsai
>            Priority: Minor
>             Fix For: 2.0.0
>
>         Attachments: HBASE-15583.v0.patch, HBASE-15583.v1.patch, HBASE-15583.v2.patch,
HBASE-15583.v3.patch, HBASE-15583.v4.patch, HBASE-15583.v5.patch, HBASE-15583.v6.patch, HBASE-15583.v7.patch
>
>
> From [~enis] in https://issues.apache.org/jira/browse/HBASE-15505:
>     PS Should UnmodifyableHTableDescriptor be renamed to UnmodifiableHTableDescriptor?
> It should be named ImmutableHTableDescriptor to be consistent with collections naming.
Let's do this as a subtask of the parent jira, not here. Thinking about it though, why would
we return an Immutable HTD in HTable.getTableDescriptor() versus a mutable HTD in Admin.getTableDescriptor().
It does not make sense. Should we just get rid of the Immutable ones?
> We also have UnmodifyableHRegionInfo which is not used at the moment it seems. 



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message